[精讚] [會員登入]
833

在CISCO上設定NAT和 DHCP

在CISCO上設定NAT和 DHCP

此文完整連結 http://n.sfs.tw/10440

複製連結 在CISCO上設定NAT和 DHCP@新精讚
(文章歡迎轉載,務必尊重版權註明連結來源)
2016-12-16 21:10:40 最後編修
2016-12-16 21:04:06 By 張○○
 

NAT 的型態

  • Static NAT  --  一個私有ip對應到一個公有ip
  • Dynamic NAT -- 一個私有ip對應到一群公有ip
  • Overlapping -- 多個私有ip對應到一個公有ip,也是我們一般認知的NAT

位址型態

  • inside global 
  • inside local
  • outside local
  • outside global

  我畫一個圖來解釋,此圖上的IP不具意義,僅供參考

架構圖

設定參數
Router2: FastEth 0/0 10.200.0.254/25 連接 PC4 ,提供PC4 DHCP
       FastEth 4/0 172.20.0.1/24 介接 Router3

Router2: FastEth 4/0 172.20.0.254/24 介接 Router2

設定

Router2

   PAT:
  •   由FastEth 0/0 進來之IP 經由FastEth 4/0出去,會帶著自訂的 myippool (172.20.0.250~172.20.0.253)其中之一出去
  •   只淮許 10.200.0.128/25 的IP進行 PAT
 

interface FastEthernet0/0
ip address 10.200.0.254 255.255.255.128
 ip nat inside 
!
interface FastEthernet4/0
 ip address 172.20.0.1 255.255.255.0
 ip nat outside
!
ip nat pool myippool 172.20.0.250 172.20.0.253 netmask 255.255.255.0
ip nat inside source list 2 pool
myippool overload

access-list 2 permit 10.200.0.128 0.0.0.127

   DHCP:
  • 排除 10.200.0.129 ~10.200.0.133、10.200.0.151~10.200.0.160
    (這兩段 cisco可以容許多個dhcp,排除的設定是設定在global而非在dhcp 內)
  • 設定dhcp network0 配發在10.200.0.128 255.255.255.128網段中、預設路由10.200.0.254和dns 163.17.40.3

ip dhcp excluded-address 10.200.0.129 10.200.0.133
ip dhcp excluded-address 10.200.0.151 10.200.0.160
!
ip dhcp pool network0
 network 10.200.0.128 255.255.255.128
 default-router 10.200.0.254
 dns-server 163.17.40.3
!

除錯

Router#sh ip nat translations
Router#
NAT: s=10.200.0.129->172.20.0.250, d=192.168.0.1[5]  出去 pkgs
NAT*: s=172.20.0.254, d=172.20.0.250->10.200.0.129[5]  回來的pkgs
NAT: s=10.200.0.129->172.20.0.250, d=192.168.0.1[6]
NAT*: s=172.20.0.254, d=172.20.0.250->10.200.0.129[6]
NAT: s=10.200.0.129->172.20.0.250, d=192.168.0.1[7]
....

參考資料

[1] cisco local and global def. http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094837.shtml
[2] NAT http://blog.yam.com/linadonis/article/21205470
[3] http://tosian.blogspot.com/2008/04/cisco-dhcp-on-cisco-switch.html


原文 2012-03-27 10:40:23

你可能感興趣的文章

FTP的主動模式及被動模式 FTP的服務常會被防火牆擋掉,所以對於主動和被動模式,需要很了解

[TCP] TCP關閉的四步程序 TCP關閉的四個步驟

在CISCO上設定NAT和 DHCP 在CISCO上設定NAT和 DHCP

在CISCO中打入中文(big5) cisco ios如果是由linux主機跳進去,我就不能打入中文,因為我的linux主機是utf8,而cisco的ios還是big5,中文字就打不進去

為我的郵件伺服器建立SPF記錄 我的郵件伺服器寄出的信常會被放到垃圾信件匣中?試試加上SPF的記錄吧。

FIREFOX設定GOOGLE翻譯搜尋引擎 在火狐上設定google翻譯成為自己的搜尋引擎

ical 的欄位(RFC2445) 最近研究 iCalendar,發現這是一個RFC2445,為了把ics塞到資料庫,得花點時間研究一下RFC。

電子郵件郵址email的格式 電子郵件email的格式和規則

[CentOS7] 使用ip neighbor指令來偵測修改其他的節點 使用ip neighbor指令來偵測修改其他的節點

NMAP 掃描方式說明 Nmap 的幾種掃瞄方式

我有話要說


限制:留言最高字數1000字,超過部分會被截掉。請注意:留言不可帶有網址,會被濾掉。 限制:未登入訪客,每則留言間隔需超過10分鐘,每日最多5則留言。

訪客留言

[無留言]

隨機好文

[jQuery] textarea 的取值和給值 HTML 的 TEXTAREA 標籤若要用 jquery 取值,不能使用 .text() 或 .html() ,使用 .

Linux shell 的date表示法 linux下SHELL中的date表示法

外匯課程經驗 有天遇到某個朋友的正妹朋友,說她有個很棒的外匯投資課程,要我們去聽,只收場地費200大洋。她又說續效最差一個月也有1%,誰還在苦哈哈上班?

APACHE的記錄檔格式 LogFormat 語法 在APACHE中有定義一些記錄的語法模版 在 /etc/httpd/conf/httpd.conf 中: LogForm

[PHP] 檢查IP是否在某個網段內 mtachcidr 要檢查IP是否在某個網段內,要寫幾行?10行?5行? 不用,只要2行。以下是我寫的 code /** * matchCI