[精讚] [會員登入]
174

[phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本

使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

此文完整連結 http://n.sfs.tw/10647

複製連結 [phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本@新精讚
(文章歡迎轉載,務必尊重版權註明連結來源)
2017-01-22 11:50:33 最後編修
2017-01-22 11:39:02 By 瘦河馬
 

使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

這是由於phpmyadmin4以後要求的mysql伺服器端版本至少要5.5.0,請注意不是用戶端的版本,我在這裡卡了不少時間,低於此版本就會出現這個錯誤。

事實上我發現就算是低於這個版本的mysql server例如5.1,還是可以使用phpmyadminn4運作順利,至少大部分的操作沒遇到問題。

除了升級伺服器端的版本外,有些狀況不能升,所以還有一個駝鳥型的解決方法:

vi phpmyadmin/libraries/common.inc.php

查找
if (PMA_MySQL_INT_VERSION < 50500) {

修改為
if (PMA_MySQL_INT_VERSION < 50100) {

即可

你可能感興趣的文章

[PHP] 如何寫callback function 召回函數(回呼函數) PHP如何寫召回函數或回呼函數(callback function)?

[PHP7] 讀取mysql資料庫的傳統方法 使用傳統預設的方法來連結mysql資料庫

利用 php 木馬作為駭客攻擊的手法 利用 php 木馬作為駭客攻擊的手法

[PHP] 類別的繼承及建構子和解構子 PHP 類別的繼承及建構子和解構子

[CodeIgniter 3] 資料庫的使用方法整理2/2 CI3 承襲 CI2,有很多的builder class可以用,依各人的使用習慣,有人喜歡一堆sql字串,有人喜歡用helper

PHP 數字加解密函式 自寫的數字加解密,勉強用

[PHP] preg_match 的貪婪和不貪婪比對 在php preg_match中預設是採用貪婪比對,太貪婪反而不符合需要,因此得採用「非貪婪比對」...

[PHP] 檢查IP是否在某個網段內 mtachcidr 要檢查IP是否在某個網段內,要寫幾行?10行?5行? 不用,只要2行。以下是我寫的 code /** * matchCI

設定Google analytics API #1 -- Google網站上的設定 讓你的網站能夠存取你的Google analytics上面的資料

[phpmyadmin] 錯誤:您應升級到 MySQL 5.5.0 或更新版本 使用phpmyadmin4出現錯誤:您應升級到 MySQL 5.5.0 或更新版本的解決方式

我有話要說


限制:留言最高字數1000字,超過部分會被截掉。請注意:留言不可帶有網址,會被濾掉。 限制:未登入訪客,每則留言間隔需超過10分鐘,每日最多5則留言。

訪客留言

[無留言]

隨機好文

[MAC] 截取螢幕畫面的方法 截取螢幕畫面的方法,在MAC中叫作螢幕快照,英文是screenshot

HP SAS硬碟leds燈號說明 HP SAS硬碟leds燈號(hp g7/g6系統適用)說明

為什麼要買長達二十年的保單? 為什麼要買長達二十年的保單?找一個可以說服我買二十年保單的理由。

TFTP Server 安裝及使用 讓設備的網路設定檔或是韌體經由TFTP拷備出來,操作的方法

此一時彼一時 我是不是易怒的人,其實我也不知道,總之我常會失控,不知道自己在幹嘛。這近生活過得浮浮的,不是很踏實,總會想太多,我甚至會