[精讚] [會員登入]
9

[Centos6] php5.3升級為php5.6

Centos6 + php5.6 升級

此文完整連結 http://n.sfs.tw/12503

複製連結 [Centos6] php5.3升級為php5.6@新精讚
(文章歡迎轉載,務必尊重版權註明連結來源)
2018-07-12 01:11:40 最後編修
2018-07-12 01:22:15 By 瘦河馬
 

無奈的情況下升級 php5.3 為 php5.6。

無奈的原因是因為某來路不明的程設師說我的php5.3太舊跑不動他的程式碼,非常豪小,算了,我就升給你跑行不行。主要參考[1]的步驟。

原系統

CentOS release 6.10 (Final) 2011年建置

PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09)

 

安裝 Remi、Epel

# wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm && rpm -Uvh epel-release-latest-6.noarch.rpm

 

修改 yum 儲存池

vi  /etc/yum.repos.d/remi.repo

把下面enabled(粉紅色)的部分設成1


[remi]
name=Remi's RPM repository for Enterprise Linux 6 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/6/remi/$basearch/
#mirrorlist=https://rpms.remirepo.net/enterprise/6/remi/httpsmirror
mirrorlist=http://cdn.remirepo.net/enterprise/6/remi/mirror
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

 

[remi-php56]
name=Remi's PHP 5.6 RPM repository for Enterprise Linux 6 - $basearch
#baseurl=http://rpms.remirepo.net/enterprise/6/php56/$basearch/
#mirrorlist=https://rpms.remirepo.net/enterprise/6/php56/httpsmirror
mirrorlist=http://cdn.remirepo.net/enterprise/6/php56/mirror
# NOTICE: common dependencies are in "remi-safe"
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi

 

升級PHP

# yum upgrade php*

如果你一切順利,恭禧你重啟後就完成法。

但是我遇到下面的錯誤:

Error Downloading Packages:
  php-fedora-autoloader-1.0.0-1.el6.noarch: failure: Packages/p/php-fedora-autoloader-1.0.0-1.el6.noarch.rpm from epel: [Errno 256] No more mirrors to try.
  libwebp-0.4.3-3.el6.x86_64: failure: Packages/l/libwebp-0.4.3-3.el6.x86_64.rpm from epel: [Errno 256] No more mirrors to try.

有兩個 packages 找不到來源,只好手動下載。

到yum暫停rpm的地方

# cd /var/cache/yum/x86_64/6/remi/packages/

下載yum無法自動找到的 packages

安裝

# rpm -Uvh php-fedora-autoloader-1.0.0-1.el6.noarch.rpm
# rpm -Uvh libwebp-0.4.3-3.el6.x86_64.rpm

重新執行 php升級

# yum upgrade php*

重啟 apache

# apachectl restart

升級完成

# php -v

PHP 5.6.36 (cli) (built: Apr 25 2018 10:11:47)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

 

參考資料

[1] https://www.zerostopbits.com/how-to-upgrade-php-5-3-to-php-5-6-on-centos-6-7/

 

你可能感興趣的文章

[CentOS] 改錯fstab 無法開機怎麼辦? Linux 改錯fstab 無法開機怎麼辦?

Centos7 的ifconfig和netstat Centos7 和RHEL 7 最小安裝中竟然沒有ifconfig和netstat?原來centos/rhel準備把這兩個指令作廢,那怎麼辦?

[Linux] 安裝rsync (selinux 的設定) 在selinux enforcing 的情況下安裝rsync

[CentOS6] 設定 sendmail Centos6上設定sendmail,基本上sendmail會設定多半是為了寄系統信和收垃圾信(喂!!?)

[Centos] 安裝及使用postfix,設定虛擬帳號及轉寄 使用postfix來設定虛擬帳號及轉寄

[Centos7] 使用網路安裝 Centos7 使用網路來安裝Centos7,雖然這不是什麼新鮮事,但可以省你的磁碟空間或光碟片

動態DNS -- dynamic DNS實作 BIND9動態DNS設定

[Centos6] 安裝VNC連線程式 在Centos6桌上環境安裝VNC 連線程式

PHP for sphinx 函式庫安裝 PECL/sphinx PHP>= 5.2.2 已經能原生支援 sphinx,可是預設的沒有裝,我們得自己裝才能用

[Centos] opentftp + selinux 安裝及設定 Centos 安裝微型ftp伺服器:tftp伺服器

我有話要說


限制:留言最高字數1000字,超過部分會被截掉。 限制:未登入訪客,每則留言間隔需超過10分鐘,每日最多5則留言。

訪客留言

[無留言]

隨機好文

為什麼要買長達二十年的保單? 為什麼要買長達二十年的保單?找一個可以說服我買二十年保單的理由。

沒有非誰做不可的事,也沒有不可被取代的人 沒有非誰做不可的事,也沒有不可被取代的人

世紀帝國征服者新版本--被遺忘的帝國 世紀帝國征服者新版本--被遺忘的帝國 世紀二代的征服者是精典遊戲中的精典,aofe更好玩...

[CodeIgniter 3] 資料庫的使用方法整理2/2 CI3 承襲 CI2,有很多的builder class可以用,依各人的使用習慣,有人喜歡一堆sql字串,有人喜歡用helper

最值得學的電腦技能 什麼是最值得學的電腦技能?程式設計?美工繪圖?系統網路?還是…? 都不是!個人覺得一個最值得學的電腦技能就